Skip to content
Advertisement

Trying to install Docker on RHEL – docker-ce conflicts with Podman-docker

Getting this error:

Updating Subscription Management repositories. Red Hat Enterprise Linux 8 for x86_64 – AppStream (RPMs) 22 MB/s | 45 MB 00:02 Last metadata expiration check: 0:00:01 ago on Mon 01 Aug 2022 17:36:44 BST. Error: Problem: problem with installed package podman-docker-2:4.0.2-6.module+el8.6.0+14877+f643d2d6.noarch

  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-2:4.0.2-6.module+el8.6.0+14877+f643d2d6.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1.0.0-2.git921f98f.module+el8+2785+ff8a053f.noarch
  • package podman-docker-1.0.0-2.git921f98f.module+el8+2785+ff8a053f.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1.0.0-2.git921f98f.module+el8.0.0+2958+4e823551.noarch
  • package podman-docker-1.0.0-2.git921f98f.module+el8.0.0+2958+4e823551.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1.0.5-1.gitf604175.module+el8.0.0+4017+bbba319f.noarch
  • package podman-docker-1.0.5-1.gitf604175.module+el8.0.0+4017+bbba319f.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.noarch
  • package podman-docker-1.0.3-1.git9d78c0c.module+el8.0.0.z+3717+fdd07b7c.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1.4.2-5.module+el8.1.0+4240+893c1ab8.noarch
  • package podman-docker-1.4.2-5.module+el8.1.0+4240+893c1ab8.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package podman-docker-1.6.4-2.module+el8.1.1+5363+bf8ff1af.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package podman-docker-1.6.4-4.module+el8.1.1+5885+44006e55.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package podman-docker-1.6.4-10.module+el8.2.0+6063+e761893a.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1.4.2-6.module+el8.1.0+4830+f49150d7.noarch
  • package podman-docker-1.4.2-6.module+el8.1.0+4830+f49150d7.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package podman-docker-1.9.3-2.module+el8.2.1+6867+366c07d6.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package podman-docker-1.6.4-11.module+el8.2.0+6368+cf16aa14.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package podman-docker-1.6.4-12.module+el8.2.0+6669+dde598ec.noarch conflicts with docker-ce provided by docker-ce-3:20.10.17-3.el8.x86_64
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-2.0.5-5.module+el8.3.0+8221+97165c3f.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-2.2.1-7.module+el8.3.1+9857+68fb1526.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-3.0.1-6.module+el8.4.0+10607+f4da7515.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-3.0.1-7.module+el8.4.0+11311+9da8acfb.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-3.2.3-0.10.module+el8.4.0+11989+6676f7ad.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-3.2.3-0.11.module+el8.4.0+12050+ef972f71.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.1-9.module+el8.5.0+12697+018f24d7.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-2:4.0.2-6.module+el8.6.0+14673+621cb8be.noarch
  • package docker-ce-3:20.10.17-3.el8.x86_64 conflicts with docker provided by podman-docker-1:3.4.2-9.module+el8.5.0+13852+150547f7.noarch
  • cannot install the best candidate for the job

Advertisement

Answer

Before starting the Docker installation, you need to remove the conflicting packages, such as the podman and buildah packages, from your system.

2 People found this is helpful
Advertisement